Cannot connect using TLS


Hello, trying to connect to your MQTT broker using with TLS using MQTT Explorer and MQTTX applications.
In both I cannot connect using port 8883 and TLS. I checked credentials many times and without TLS (using 1883 port) port I can connect and everything work fine. I can also connect with other MQTT brokers on port 8883 without any issues so this is not network/firewall. I’m using this I have tried diffrent MQTT protocol versions - without luck… I like your service - specificlly Filters work great but I wish I could connect using TSL on port 8883 for security reasons… No error pop in just tring connect for some time than again and again…without success.


Hello Maciej,

On 18th december we applied an upgrade to include TLSv1.3 for MQTT TLS connections (port 8883). Part of that upgrade disabled TLSv1.0 and TLSv1.1 as default settings recommended by vendor.

After some error reporting, we have reenabled them (TLSv1.0 and TLSv1.1) as well as TLSv1.3. Having that fixed, can you check if that is the problem?

Let us know,
Best Regards,


Hello Christian,

I’ve just tried now 21.12.2023 10:29 in Poland. Still not working on port 8883. On port 1883 works like a charm.
Which MQTT version should i use? Because from my observations MQTT 3.0 and 3.1.1 works and mqtt 5.0 not.
I will try it not using 3rd party software but my own code if it works. Maybe some details go on daylight.


Hello Maciej,

We have been working on the issue and going further with old protocol support. After some changes, we are now supporting again old systems (like OpenSSL 0.9.8 TLSv1.0/TLSv1.1).

Could you check if it is now working for you?

Also, could check to run the following command to see if it connects and reports as indicated (update command with some credentials from your HUB):

>> mosquitto_sub --capath /etc/ssl/certs/ -d -v -h -p 8883 -i (aClientId) -u (aClientId) -P '(aPassword)' -t message/topic/to/subscribe -q 2 Client device002 sending CONNECT Client device002 received CONNACK Client device002 sending SUBSCRIBE (Mid: 1, Topic: message/topic/to/subscribe, QoS: 2) Client device002 received SUBACK Subscribed (mid: 1): 2

About your question, currently support MQTT 3.0, 3.1 and 3.1.1.

Let see these details for next steps.

Best Regards.