Public Panel with buttons / Panel publico con botones


I created a public panel with actionable buttons. The buttons activate a relay. While using the panel in a browser already logged into MyQtt, buttons work as expected. When I use the panel and a different device (cell phone) or another browser, they do not work at all… What am I doing wrong? TKS

Tengo creado un panel publico con botones activos. Los botones activan un rele. Mientras se use el panel en un explorador ya conectado a una sesion de MyQtt, los botones funcionan correctamente. Si utillizo el panel en un dispositivo distinto (celular, por ejemplo) o en otro explorador, no funcionan. Que estoy haceindo mal? GRACIAS



About "when I use the panel and a different device (cell phone) or another browser, they do not work at all", what’s the error you are getting? (screenshot, full error detail)


Hi Ricardo, thanks for the reply. No error. Nothing happens…

Here is the URL (no worries on sharing since its test panel):



Good :slight_smile:

I’m testing the public reference and we see it running: :thinking:

We have tested too with several browsers and same (responsive) result.

You just get a blank page? Nothing else?

What does do your device if you just load plain

You should get something like:

What does yours?



Hola Ricardo

Thanks again for your response! So, let me explain what I am expecting to happen

As you can see in my panel, there are two buttons, ON and OFF. Underneath the buttons there’s a status: Light is: OFF or ON. There’s a a toggle (with status) which slides from side to side accordingly when the buttons are pressed.

So, what happens when one of my browser tabs is connected (it has to be connected) to when I click on ON, the toggle slides and the status changes to “light is: ON”. On my ESP module, the internal LED goes on. If I click on the OFF button, the opposite happens.

So far, all is good

Now, if I log-off or change browsers or change device (which are NOT connected to and access the public panel, and click, say on the ON button, I then see the pup-up saying the message was sent to “inTopic” but nothing else happens. The status does not change on the panel nor does the LED on my module change.

I then tried from MQTT Explorer. I can send messages to my topic, the LED changes status (goes on or off) on my local ESP. The panel status however, remains “frozen”. So, in summary, the public panel only seems to operate when browser I am viewing it in, has a tab logged into

In the device i have set to ON the “enable skip connection replace” option. I also tried activating the “Skip session IP enforce” option and nada, same situation…

When I run a private/incognito session in my browser the buttons dont change the status either…