How to create_Broker -- Connecting to


How can I create a broker connection, I am getting an error that says “MQTT Client is not connected to broker” can any one help please?



Because is a professional, production ready environment, you need to create devices to connect to your HUB. does not allow anonymous/testing access. For that:

  1. First create devices (credentials) you are going to use to connect to your MQTT HUB:

    How to create and manage your MQTT devices with

  2. Alternatively, you can also enable SCI auth for simple client id authentication:

    How to use SCI Auth -- Simple Client-ID autentication to connecto your MQTT Devices to

  3. Even you can reuse same credentials by disabling MQTT connection replace (but only useful for publish or highly concurrent scenarios):

    Connecting several devices with same credentials (how to avoid MQTT connection replace, connection replacement)

  4. Once done, configure that settings into your MQTT connecting devices. If you need additional indications, we really recommend you take a look at “ manual”. There is plenty of useful information to get up and running with your MQTT solution:

    MyQttHub EN -- Start here

Let us know your progress
Best Regards

If you liked :heart:, spread the word :loudspeaker:, and help us by following us at :star_struck: :wink: