Connecting to MyQttHub with mqtt-explorer.com application (mqtt explorer, mqttexplorer)


#1

1. Introduction

Here are some recommended steps to connect to your MyQttHub using MQTT tls (secure session).

Before continue please create a device if you don’t one by following steps at:

Jot down clientId, userName and password as they will be required by your mqtt-explorer.com solution

2. Configuring mqtt-explorer.com application

  1. After installing application, configure initial settings ensuring you have:

    Host: node02.myqtthub.com
    Port: 8883
    TLS: enabled
    TLS verification: enabled
    Username and password (as created at your hub):

  2. After clicking on Advanced, set there clientId associated:

  3. Now click connect. If everything was setup correctly you’ll see mqtt-explorer dashboard:

3. Using Bootstrap auth

MQTT Explorer uses a configuration with a random clientId that you can configure to make it fixed (as we saw earlier). In case you want to configure several MQTT Explorers or keep on using auto generated clientId by MQTT Explorer, you can create a bootstrap credential to allow authentication by just providing userName and password.

For that, take a look at the following article:

4. Known errors

  1. getaddrinfo ENOTFOUND node02.myqtthub.com

    This error is indicating that there is a DNS problem causing node02.myqtthub.com to be not resolved to the IP associated. Check your system DNS settings to correct them. You should be able to visit https://node02.myqtthub.com without any issue. Once that happens, MQTTexplorer should work as expected.


Server unavailable
MyQttHub EN -- Start here
Sonoff "mini" with Tasmota 6.5.0 seems to have a problem with MyQttHub
Can't connect - New account